sabato 25 ottobre 2008

Intrepid, Xorg, Nvidia e GeForce 4

Una delle cose con le quali ho sempre fatto pubblicità a Linux è stata la compatibilità con il vecchio hardware e la capacità di tirarne al massimo le risorse: sul mio caro Toshiba di ormai quasi 6 anni Compiz e Kwin4 girano ottimamente (mentre Vista non ne vorrebbe nemmeno sapere di essere installato!!!). Purtroppo ieri ho scoperto con notevole disappunto dalle note di rilascio della RC, anche se poi ho visto che era una informazione nota già da tempo, che Xorg 7.4 installato sull'Intrepid ha delle incompatibilità con i driver legacy closed nvidia-glx per cui, allo stato attuale, installando la 8.10 si viene dirottati sui driver nv open, senza accelerazione 3D. Al di la' delle finestre svolazzanti e del cubo, funzionalità come la miniatura delle finestre, la presentazione simil-expose, il cover switch sono strumenti che migliorano l'attività quotidiana e delle quali non riesco più a farne a meno. In Nvidia dicono che ci stanno lavorando sopra, speriamo di non dovere attendere molto, anche perché altre soluzioni non sembra che ce ne siano (almeno a breve). Risultato: per ora non installero l'Intrepid e sarò costretto a rimanere con la Hardy :(

EDIT 30/10/08 : ho appena letto sul forum nvidia che è stata rilasciata una versione legacy, sia pur beta, compatibile con Xorg 7.4 e a quanto pare, dai pareri degli utenti funziona, anche se con qualche piccolo tip. Grazie Nvidia per il tuo supporto, ora potrò andare a provare lo stambecco intrepido!!!

8 commenti:

Marco ha detto...

Ciao,anch'io ho un vecchio notebook Toshiba (2450 - S203) con scheda video NVIDIA GeForce4 420 Go 32 MB. Mi sembra di aver capito che siano stati rilasciati da tempo dei driver da NVIDIA ( i 96, se non ho capito male) che supportano la scheda su Ubuntu Intrepid. Ho anche tentato di installarli, ma lo schermo è diventato monocolore (sfumatura da nero a bianco) al riavvio e ho dovuto ripristinare i driver generici nv.
Ho sbagliato qualcosa? Come devo fare per installare facilmente questi driver NVIDIA "96"? Mi confermi che senza di essi Google hearth non funziona? Sono un neofita di Ubuntu, ma credo molto nella sua filosofia e soprattutto devo vincere una scommessa con mia moglie che ritiene Intrepid un'inutile complicazione.
Grazie dell'aiuto, se potrai darmelo. Ciao, Marco (azzurro chiocciola libero punto it)

catanzag ha detto...

Ciao Marco,

ti rispondo velocemente perché ho solo un attimo, scusami ma solo per caso ho acceso il computer ora e ho visto il tuo post; allora, Google Earth mi pare voglia le opengl, credo che possa funzionare pure senza i driver proprietari e accelerati nvidia (tramite l'emulazione sw delle opengl con mesa) ma credo sia molto, molto più lento, anche se non l'ho mai provato.

Per configurare il driver con il server X11 devi modificare il file /etc/X11/xorg.conf; ho messo il mio, perfettamente funzionante (dopo lunghissime prove nel passato...) qui su pastebin e il mio pc funziona perfettamente; non garantisco nulla, ma puoi provarlo, forse ti risolve i problemi che anche io nel passato ho avuto, da un'occhiata ai miei post precedenti. L'unica cosa che devi fare è scaricarti il firmware della scheda da questo post del forum nvidia. Ora ti devo lasciare, buone prove!!!

catanzag ha detto...

Scusa, un po' di ruggine con l'html. Ecco i link del mio xorg.conf e del firmware della GeForce 420 Go

Lorenzo ha detto...

ciao catanz, è un pò che non ci sentiamo, come ti dicevo ho un toshiba 2410 uguale al tuo...ho aggiornato a ubuntu 9.04, driver nvidia proprietari installati, tutto ok, ma google earth non funge...mi fa vedere la mappa del pianeta tutta bianca e gialla...ne sai qualcosa?

catanzag ha detto...

Ciao Lorenzo, piacere di risentirti!!! Ho provato a lanciare googleearth (ho la 5.0.11337.1968 scaricata non so quando...) e anche io vedevo tutto bianco e giallo (!). Poi sono andato sul menu Visualizza->Immagini storiche e poi con il cursore sono tornato indietro di un paio di giorni e mi sono ricomparse le foto da satellite: provaci anche tu e fammi sapere.

Ciao

Nico Morea ha detto...

Salve, ho un portatile toshiba 2410-603 con questa sheda video:NVIDIA GeForce4 420 Go AGP 4x. Ho installato ubuntu con i driver i 96
Ho seguito diverse guide che ho trovato su google. i driver che ho installato sono i 96 compresi del programma setings della scheda video quindi dell'accellerazione
3D. il risultato migliore ottenuto e risoluzione a 969-768 con visualizzazione in 3D e lo schermo mi presenta una striscia nera sul lato destro. vi prego aiutatemi altrimenti dovro rinunciare a linux e la cosa mi dispiacerebbe davvero tanto. Nico Morea

catanzag ha detto...

Ciao Nico, scusa se ti rispondo solo ora, sono stato senza internet per un bel po' di tempo (e ora non è che abbia risolto in pieno...). Allora, il problema delle bande nere deriva dal fatto che la scheda legge male i dati EDID del monitor LCD e si confonde, ma è facilmente risolvibile; basta che scarichi il firmware della 420 (guarda il terzo commento di questo post per i link), lo decomprimi con tar zxvf custom_edid.tar.gz e lo metti, ad esempio, in /etc/X11 . Poi aggiungi nel file /etc/X11/xorg.conf nella sezione "Screen" la riga Option "CustomEDID" "DFP-0:/etc/X11/420_custom_edid.bin" così come puoi vedere nel mio xorg.conf (vedi sempre il link in quel commento).

In bocca al lupo e fammi sapere

Ciao

Giorgio

Nico Morea ha detto...

Ciao Giorgio, (scusami per il ritardo,ho risposto via mail solo ora ho notato che il messaggio non era arrivato)

grazie per avermi risposto, ho risolto il problema seguendo le indicazioni del punto tre di questo link, credo siano sovrapponibili alle tue indicazioni.
http://natonelbronx.wordpress.com/2007/04/21/ubuntu-schermo-nero-al-riavvio-dopo-laggiornamento-a-feisty-fawn-704-nvidia/
Ora sto incotrando qualche altro problema con ubuntu, i quali mi stanno un pò scoraggiando, sono molto nuovo nell'uso di ubuntu (due mesi). mi piacerebbe scambiare qualche parola con te se sei disponibile. Per confrontarmi e per evitare di abbandonare totalmente ubuntu. intanto ti lascio la mia mail nicomorea@gmail.com
poi ti lascio un mio numero di tel.
grazie ancora
nico